О переходе на PHP 7.3 региональной панели хостинга

Уважаемые коллеги!

На региональном хостинге 68edu.ru в течение 2019 года запланирован перевод сайтов, размещенных на сервере с панелью управления хостинга https://vds1.68edu.ru на программное обеспечение PHP 7.3.

Необходимо протестировать сайты образовательных учреждений на корректность их  работы с версией PHP 7.3 (WordPress, Joomla).

В случае, если платформа сайта не совместима с PHP 7.3, то Вам необходимо предпринять меры по обновлению сайта.

Версия PHP 5.6 в качестве альтернативы останется доступной для выбора в панели управления хостинга https://vds1.68edu.ru

На сервере с адресом панели управления хостинга https://isp.68edu.ru изменений производиться не будет.

PHP 7.3

 

Почему необходимо обновить PHP?

PHP 5.6 станет минимальным требованием для WordPress в апреле 2019 года, а его замена на PHP 7.0 произойдет уже в декабре 2019 года.

PHP является одним из самых популярных языков в Интернете. Фактически, 70% всех веб-сайтов используют PHP на стороне сервера.

Активная поддержка PHP 5.6 закончилась 19 января 2017 года, и она официально завершит свой жизненный цикл 31 декабря . Это означает, что у нее больше не будет поддержки безопасности, и сайты, которые продолжают использовать PHP 5.6, будут иметь незакрытые уязвимости.

Кроме того, есть PHP 7.0, срок службы которого истек 3 декабря 2018 года. Он также больше не является поддерживаемой версией PHP. Т

Как и любое программное обеспечение, PHP имеет жизненный цикл. Каждая основная версия PHP обычно полностью поддерживается исправлениями ошибок и исправлениями безопасности в течение двух лет после ее выпуска.

Почему вы должны перейти на PHP 7+

PHP 7.+ теперь не только официально включен в список рекомендуемых требований для WordPress , но и имеет множество преимуществ в плане скорости, производительности и безопасности .

1. Скорость и производительность

Обновление PHP до последней версии даст вам немедленный прирост производительности  сайта— больше, чем любая другая настройка сайта WordPress.

Когда был выпущен PHP 7.0, он получил признание за значительный прирост производительности. Фактически, официальный тест PHP с использованием WordPress 4.1.1 показывает, что PHP 7.0 позволяет серверам выполнять вдвое больше запросов в секунду, чем PHP 5.6 с вдвое меньшей задержкой.

Результаты тестов показывают, что PHP 7.3 выполняет в 3 раза больше запросов в секунду по сравнению с PHP 5.6.

2. Поддержка и совместимость

Совместимость — еще одна важная причина, по которой вы должны использовать последнюю версию PHP. Как и в любом программном обеспечении, разработчики будут поддерживать старые версии PHP в своих плагинах и темах только в течение определенного периода времени. Это приведет к тому, что активная поддержка старого программного обеспечения и обеспечение обратной совместимости будет невыгодной для разработчиков плагинов и тем.

3. Безопасность

Еще одна фундаментальная причина, по которой необходимо обновить PHP — это безопасность вашего сайта WordPress. Использование последней версии PHP гарантирует, что ваш сайт защищен от уязвимостей, выявленных в более старых версиях PHP.

Например: согласно данным CVE об уязвимостях безопасности, в этом году в PHP было обнаружено 18 известных уязвимостей. В 2017 году было обнаружено 43 уязвимости, а в 2016 году было обнаружено огромное количество 107 уязвимостей.
Эти уязвимости включают DoS, выполнение кода, внедрение SQL, XSS и многие другие типы эксплойтов.

В WordPress рекомендуется постоянно обновлять версии ядра, плагинов и тем WordPress. Аналогично, чтобы избежать уязвимостей в безопасности, вы также должны поддерживать свою версию PHP в актуальном состоянии.

Проверка PHP-совместимости

 Перед обновлением вы также должны проверить, что ваши плагины и темы совместимы с последней версией PHP.

Для этого можно использовать плагин WP Engine PHP Compatibility Checker. Этот плагин сканирует ваш сайт и проверяет, какие плагины совместимы с тремя последними версиями PHP. Скачать плагин можно сдесь https://wordpress.org/plugins/php-compatibility-checker/

После установки и активации плагина в пункте “Инструменты” появится новый подпункт “PHP Compatibility Checker”, где можно запустить проверку на совместимость вашего сайта с более новыми версиями php:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Если какие-либо плагины не соответствуют PHP 7.3, необходимо обновить их.

Успехов!

Комментарии закрыты.